Home > Total War : Warhammer 2 – Mods Not Working FIX

Total War : Warhammer 2 – Mods Not Working FIX

Fix The Mods With New Launcher Method 1: Fix the launcher Do right click at name […]

Fix The Mods With New Launcher

Method 1: Fix the launcher

  1. Do right click at name of this game in list and select properties.

2.Go to BETA tab and select launcher_release_candidate

3.Then close the window and wait for download to complete, then run the game, select some mods are updated and enable them, then run the game and you may load your game if this mod is save game compatible.

4.The mod worked, I’m using New World Versus Old World – UI Overhaul

5.Then exit the game and repeat the first step, now select none in BETA tab and close the window.

6.Re-enable the mods again in new launcher.

7.It should work after all as it’s in my game. (I assume they changed settings each you change the launcher, not sure how it happened.)

Method 2: Move the mod files.

If you have subscribed the mods and you tought those mods didn’t work, follow this:

1.Go to C:\Program Files (x86)\Steam\steamapps\common\Total War WARHAMMER II and open used_mods.txt to identify what’s the route you subscribed the mod.

2.Select one of the mods and copy this route like “C:/Program Files (x86)/Steam/steamapps/workshop/content/594570/XXXXXXX”

3.Paste in the path field in windows explorer, you see 2 files you need to copy these files.

4.Then go to C:\Program Files (x86)\Steam\steamapps\common\Total War WARHAMMER II\data and paste the files you have copied mod files from workshop folder to this data directory.

That’s all, make sure the mods are enabled in launcher. I got 2 mods are working now since they didn’t work in the launcher.

  • Immersive Battle Banners
  • Building Progression Icons

Leave a Comment

Your email address will not be published. Required fields are marked *